Ticket #115 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[BuildSys] Fix parallel builds and plugin-specific interfaces clean target

Reported by: tim Owned by: tim
Priority: critical Milestone: RC2009
Component: Fawkes Version:
Keywords: buildsys Cc:
Git Branch:

Description

Currently building in parallel (make -j) often fails, additionally the clean target for plugin-specific interfaces does not work as expected. The interface.mk file has to be modified to get this fixed. Other Makefiles might need some tuning, like adding order prerequisites.

Change History

comment:1 Changed 11 years ago by tim

  • Status changed from new to assigned

comment:2 Changed 11 years ago by tim

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed in r2521.

comment:3 Changed 11 years ago by tkellner

  • Status changed from closed to reopened
  • Resolution fixed deleted

Parallel builds still fail sometimes.
This time, the culprit was the interface generator:

[...]
      --> Entering sub-directory utils ---
[...]
      --> Entering sub-directory ../interfaces ---
[...]
         === Linking interface_generator ---
         --- Compiling fawkesutils_tolua.cpp (C++)
/usr/bin/ld: cannot find -lfawkesutils
collect2: ld returned 1 exit status
make[4]: *** [/home/tkellner/nao_fawkes/bin/interface_generator] Error 1
make[3]: *** [.objs_nao] Error 2
make[2]: *** [../interfaces] Error 2
make[2]: *** Waiting for unfinished jobs....
         === Linking lib libfawkesutils ---
         === Linking lib lua/fawkesutils ---
         <-- Leaving utils
make[1]: *** [libs] Error 2
make: *** [src] Error 2

comment:4 Changed 11 years ago by tim

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the report. This does only happen in the Nao branch because it has a special "../interfaces" target in the libs Makefile. This was lacking an ordering constraint for the dependency on the utils. The localization plugin was proken in a similar way. These have been fixed in r2579.
Complete parallel build with cleaned ccache works now just fine. Please confirm. Beware of the NaoQi shit, it eats all the RAM it can find on parallel build. Limit number of parallel jobs (e.g. "-j 2") or have lot of free RAM (>> 2GB).

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Subscriber, Participant

  • Fawkes Trac List(Always)
  • Tim Niemueller(Reporter, Owner, Participant)