Ticket #156 (closed defect: worksforme)

Opened 7 years ago

Last modified 7 years ago

zombie config values

Reported by: vmatare Owned by: tim
Priority: major Milestone:
Component: Fawkes Version: 0.4.2
Keywords: Configuration Cc:
Git Branch:

Description

Configuration::search() returns an old config value for /firevision/retriever/camera/cam1 that doesn't exist in cfg/default.sql. Removing the path from default.sql yields:

FawkesMainThread: Default config value ERASED:  /firevision/retriever/camera/cam1

But then in the same startup sequence:

FvBaseThread: Thread 'FvRetrieverThread_cam1' registers for camera 'v4l2:front:device=/dev/video1:size=160x120:auto-white-balance=1:exposure=0'

Basically, there's no way (except hardcoding it in fvretriever_plugin.cpp) to change or remove that value.

Change History

comment:1 Changed 7 years ago by tim

I suspect it has been set in the host config. If so, this problem will be solved by the new YAML configuration. Please do

sqlite cfg/HOSTNAME.db
SELECT * FROM config WHERE path='/firevision/retriever/camera/cam1';

If this returns results this is indeed the problem.

comment:2 Changed 7 years ago by bahram

Alternatively you can run

./ffconfig list

after having started fawkes, and see if that config flag appears. Judging from your report, it should appear and there should not be a "*" in front of it, meaning that it is a host entry.
You can delete that entry with ffconfig, check

./ffconfig -h

to get the proper command for that.

comment:3 Changed 7 years ago by tim

Victor, can you provide the requested information? Otherwise we'll close this ticket as not a bug.

comment:4 Changed 7 years ago by vmatare

  • Status changed from new to closed
  • Resolution set to worksforme

The steps above weren't done with 0.4.2 and the problem isn't reproducible any more since 0.5.0. So I guess this can be closed.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Subscriber, Participant

  • Bahram Maleki-Fard(Participant)
  • Fawkes Trac List(Always)
  • Tim Niemueller(Owner, Participant)
  • Victor MatarĂ©(Reporter, Participant)