wiki:FawkesDependencies

Version 12 (modified by tim, 12 years ago) (diff)

Updated libdc1394 and vmc

Fawkes Dependencies

Here is a list of current Fawkes dependencies. We try to minimize the number of dependencies but some are needed. Please verify your system carefully if it matches the criteria. Check all version numbers! If you are working with Fawkes for the first time and cannot get it to compile and consider sending a team member an email please include all version information about the packages mentioned here, whether they are exactly the same or higher. If any version is lower than what is mentioned here upgrade that package - we cannot help you in that case.

This information has to be replicated in the file source:trunk/doc/DEPENDENCIES in the Fawkes tree because there may be users that get the software without access to this website. But since this website will be the main source for information and since it is better readable we want this information to be here, too.

Mandatory dependencies

These are must-have items. If anything is not installed or installed in a lower version it will most probably not work.

ModuleDependencyVersionNotes
FawkesLinux kernel>= 2.6.17older versions will not work||
Fawkesmake>= 3.81needed for second expansion
FawkesGNU Compiler Collection>= 4.1
FawkesGNU Standard C++ Library>= 4.1included in GCC, but separate package on Fedora
Fawkesglibc>= 2.3
FawkesSQLite>= 3.3Configuration subsystem uses SQLite
FawkesOpenSSL>= 0.9.7WorldInfoTransceiver Encryption

Optional dependencies

Having this will reveal more features and make the software more useable or will scratch another specific itch. Install if needed.

ModuleDependencyVersionNotes
FawkesSubversion>= 1.3needed if you want to use the version control system
Fawkeslibxml++>= 2.14.0needed to build interface_generator, only needed when developing interfaces
FawkesGTS>= 0.7.6needed to build navigator plugin
FawkesVMC= 0.95needed to build navigator with real motor support
Fawkeslibiowkit>= 1.5.0needed to access the IOWarrior (kicker)
FawkesAvahi>= 0.6Used for automatic peer and service detection, required on the robots
FireVisionlibdc1394>= 2.0.0rc7.svn443needed for Firewire support
FireVisionlibraw1394>= 1.2.1 (FC6)
FireVisionIntel IPP= 5.1used in filters, free university version available
FireVisionlibjpeg>= 6b-36.2.1optional image reader/writer/compressor
FireVisionlibpng>= 1.2.8optional image reader/writer
FireVisionleutron>= 1.96.204frame grabber for old Leutron PCs
FireVisionmvslib>= 1.10needed to compile sulphur for mvBlueLYNX
FireVisionTriclops SDK>= 3.2.0.8PTGrey Bumblebee2 support, see FireVisionTriclops

How to get dependencies

Most of the dependencies should be met by a recent Linux distribution, Fedora Core 6 and upwards is preferred and supported.

For dependencies that are not fulfilled by the distribution itself have a look at /home/robocup/fawkes/dependencies on our file server.