wiki:FawkesDependencies

Version 4 (modified by tim, 13 years ago) (diff)

Added Linux kernel version 2.6.17 dependency

Fawkes Dependencies

Here is a list of current Fawkes dependencies. We try to minimize the number of dependencies but some are needed. Please verify your system carefully if it matches the criteria. Check all version numbers! If you are working with Fawkes for the first time and cannot get it to compile and consider sending a team member an email please include all version information about the packages mentioned here, whether they are exactly the same or higher. If any version is lower than what is mentioned here upgrade that package - we cannot help you in that case.

This information has to be replicated in the file source:trunk/doc/DEPENDENCIES in the Fawkes tree because there may be users that get the software without access to this website. But since this website will be the main source for information and since it is better readable we want this information to be here, too.

Mandatory dependencies

These are must-have items. If anything is not installed or installed in a lower version it will most probably not work.

ModuleDependency and VersionNotes
FawkesLinux kernel >= 2.6.17older versions will not work||
Fawkesmake >= 3.81needed for second expansion
FawkesGNU Compiler Collection >= 3.4.4This is the FC3 compiler and a guess at the moment, 4.1 recommended
Fawkesglibc >= 2.3
FawkesAvahi >= 0.6Used for automatic peer and service detection
FawkesSQLite >= 3.3Configuration subsystem uses SQLite
FireVisionlibdc1394 >= 2.0.0rc3
FireVisionlibraw1394 >= 1.2.1 (FC5)
FireVisionIntel IPP == 4.1p-8used in filters, free university version available
FireVisionlibjpeg >= 6b-36.2.1
FireVisionlibpng >= 1.2.8

Optional dependencies

Having this will reveal more features and make the software more useable or will scratch another specific itch. Install if needed.

ModuleDependency and VersionNotes
FawkesSubversion >= 1.3Needed if you want to use the version control system, older version may suffice to checkout
Fawkeslibxml++ >= 2.14.0Needed to build interface_generator, only needed when developing interfaces
FireVisionleutron == 1.96.001frame grabber for old Leutron PCs
FireVisionmvslib >= 1.10needed to compile sulphur for mvBlueLYNX