wiki:FawkesDependencies

Version 7 (modified by beck, 13 years ago) (diff)

--

Fawkes Dependencies

Here is a list of current Fawkes dependencies. We try to minimize the number of dependencies but some are needed. Please verify your system carefully if it matches the criteria. Check all version numbers! If you are working with Fawkes for the first time and cannot get it to compile and consider sending a team member an email please include all version information about the packages mentioned here, whether they are exactly the same or higher. If any version is lower than what is mentioned here upgrade that package - we cannot help you in that case.

This information has to be replicated in the file source:trunk/doc/DEPENDENCIES in the Fawkes tree because there may be users that get the software without access to this website. But since this website will be the main source for information and since it is better readable we want this information to be here, too.

Mandatory dependencies

These are must-have items. If anything is not installed or installed in a lower version it will most probably not work.

ModuleDependencyVersionNotes
FawkesLinux kernel>= 2.6.17older versions will not work||
Fawkesmake>= 3.81needed for second expansion
FawkesGNU Compiler Collection>= 4.1
Fawkesglibc>= 2.3
FawkesAvahi>= 0.6Used for automatic peer and service detection
FawkesSQLite>= 3.3Configuration subsystem uses SQLite
FawkesOpenSSL>= 0.9.7WorldInfoTransceiver Encryption
FireVisionlibdc1394>= 2.0.0rc5
FireVisionlibraw1394>= 1.2.1 (FC5)
FireVisionIntel IPP= 5.1used in filters, free university version available
FireVisionlibjpeg>= 6b-36.2.1
FireVisionlibpng>= 1.2.8

Optional dependencies

Having this will reveal more features and make the software more useable or will scratch another specific itch. Install if needed.

ModuleDependencyVersionNotes
FawkesSubversion>= 1.3Needed if you want to use the version control system, older version may suffice to checkout
Fawkeslibxml++>= 2.14.0Needed to build interface_generator, only needed when developing interfaces
Fawkeslibiowkit>= 1.5.0Needed to access the IOWarrior
FireVisionleutron>= 1.96.204frame grabber for old Leutron PCs
FireVisionmvslib>= 1.10needed to compile sulphur for mvBlueLYNX
FireVisionTriclops SDK>= 3.2.0.8PTGrey Bumblebee2 support, see FireVisionTriclops

How to get dependencies

Most of the dependencies should be met by a recent Linux distribution, Fedora Core 6 and upwards is preferred and supported.

For dependencies that are not fulfilled by the distribution itself have a look at /home/robocup/fawkes/dependencies on our file server.